Jump to content

Tim/Rodeo314

Economy class
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Tim/Rodeo314

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Good point; issue is: 18:33:35 e: Exception in XPluginStart: Couldn't open file: /Volumes/Z4ALL/XP_DEMO_V_11/Custom Scenery/scenery_packs.ini I had just deleted preferences and scenery and run the updater to make sure I had clean demo, this was the initial X-Plane launch without a scenery_packs.ini file. I do tend to sometimes delete the scenery_packs.ini so that X-Plane regenerates it (if you keep the Custom Scenery folder organized by name, deleting and letting X-Plane make a new one is easier than hand-editing said file; Mac users can't use xOrganizer). Plugin should be able to handle this gracefully? Whatever it needs to look for, if there is no scenery_packs.ini SAM should be able to safely (and correctly) assume all airport-type or overlay-type packages (which I what I gather SAM only really cares about) will get loaded by X-Plane? I guess X-Plane does actually skip packages where it finds an apt.dat with a version number newer than the version of X-Plane (e.g. sceneries with 1100 apt.dat files do get skipped by XP10), but that's about it.
  2. I just haven't really bothered upgrading. You should probably indicate the minimum macOS version somewhere, especially since it doesn't match the X-Plane 11 system requirements for macOS. BTW, we can turn that question around: is there a specific reason why you plugin requires macOS 10.13 or later?
  3. First, just a note that https://forum.aerosoft.com/index.php?/files/file/5007-sam-scenery-animation-manager/ lists "X-Plane 10 Version 10.00+"; I gather the Aerosoft forum doesn't allow for specifying an XP11 version, but may I suggest setting the "X-Plane 10 version" to either 11.10+ (11.10 required since you use new SDK 3.0 packaging rules) or at least "Not applicable"? Then, perhaps more importantly, your macOS plugin appears to be built against macOS 10.13: Load command 8 cmd LC_VERSION_MIN_MACOSX cmdsize 16 version 10.13 sdk 10.13 …whereas X-Plane 11 itself can run all the way back to macOS 10.10: https://www.x-plane.com/kb/x-plane-11-system-requirements/ Since you're most likely not using any macOS 10.13+ only APIs, specifying -mmacosx-version-min=10.10 should be enough to ensure compatibility with 10.10 or later, regardless of the SDK used. Regards, Tim
×
×
  • Create New...

Important Information

Please read the Terms of Use