Jump to content

Boeing 737-900 Engine shut down after a few seconds on max throttle, unable to lift off.

Recommended Posts

I run X-Plane on macOS Catalina and it works great with all the aircrafts, however when i try flying the 737-900U i am hit with an issue where the engines shut off after a few seconds of max throttle, and i have never been able to take off on the 737-900U. i tried cold and dark startup as well as launching the simulator with engines on and both of these options result in the engine shutting off just after a few seconds from max throttle. Please help me fix this issue or let me know if there is something i need to do in order to fix this. Thanks in advance, Good Day.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

Please read the Terms of Use