Jump to content
SwedgeHouse

Aircraft with custom datarefs

Recommended Posts

First, I want to say that I LOVE this new plugin.  I've barely scratched the surface, having only retrofitted a few smaller airports.

I am having trouble getting various airliners to actually connect with the jetways.  My understanding is that the fuel flow must be zero, and the beacon light must be off for the gate to extend and connect. I think some of the more complex aircraft use custom datarefs and the plugin isn't able to read either the fuel or beacon state.  Thus the gates never connect.

I've noticed problems with the following - each loaded in a cold and dark state:

Flight Factor A320
Flight Factor B757
Flight Factor B767

Any ideas about how to make these aircraft compatible with the SAM plugin?

Thanks!!

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the kind words.

Your guess is correct as far as the custom datarefs are concerned.  I didn't check the 757/767 on that but will do today. The A350 and B757/B767 work for me. Keep in mind that the door location is a bit higher on heavy aircraft so make sure you are in the limits. You can manually change them in the Installation tab after applying the template. We are already in touch with Flightfactor but without any solution yet.

We'll keep the supported aircraft list up to date:

Although the automatic connection might not work the manual one will do. Go to the user menu where you can connect the jetway manually if the automatic option is disabled.

Edited by Marten@Stairport

Share this post


Link to post
Share on other sites

It’s funny that you were able to get the manual connection to work, because I was not, on the 757 or the A320. I load the aircraft parked exactly on the ramp line, and when I go into the settings and enable manual mode, none of the buttons are clickable.
I manually set the door location for all aircrafts, so I think that’s ok.
I’ll look some more today and see what I can find.

Thanks!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Ah that's the problem. NEVER EVER change a door location. This option is actually only for us to configure the aircrafts. We might hide this option for you so you don't change anything accidentally.

Redownload the plugin to get the original aircraft database and try it again.

Edited by Marten@Stairport

Share this post


Link to post
Share on other sites

Ah, ok. I’ll do that.
Funny that changing the door location by a very little bit should break all the animations. I think this option should absolutely be removed for the end user in that case.
I misunderstood what it was for - I thought it was to allow the user to tweak the position of then jetway, since some of the default ones are a little bit off. Especially in regards to the airplane door hitting the jetway in its open position.
I’ll re-download and see what I get. Thanks for the quick support!
:-)


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
7 minutes ago, Evan Purcell said:

I misunderstood what it was for - I thought it was to allow the user to tweak the position of then jetway, since some of the default ones are a little bit off.

Yeah that was my initial thought as well 😄 Normally jetways should only be tweaked if you created a custom jetway as described in the live stream.

If you post your Jetway - Aircraft testcase where it is not fitting well we will try to fix it.

Share this post


Link to post
Share on other sites

No custom jetways, just using the library that comes with the plugin.
I forget which aircraft, but I noticed that the forward edge of the jetway was clipping into the aircraft door in the open position. It’s not a big deal, just me being super picky - I’ll leave well enough alone now.
Thanks again!!


Sent from my iPhone using Tapatalk

  • Thanks 1

Share this post


Link to post
Share on other sites

ok @Marten@Stairport now I'm having all kinds of trouble...

I was able to create an airport using jetways and docking guides, and could connect without an issue.  However, I'm working on another airport, and I believe I have everything setup correctly, and i can't get even the default 737-800 to connect.  The DGS poles work well, but even with the LR aircraft I can't make the jetways connect with the plane, in automatic or in manual mode.

Using the SAM config menu I can force the jetways to attach, and all the settings look good.  However, when using the plugins, nothing happens.

I have done a clean install of the plugin, using a fresh download, and re-built the SAM config for the airport from scratch.

Help!

I've attached my log.txt, the SAM.log, and the sam file in the airport folder.

Thanks!

Log.txt

SAM.log

sam.xml

Share this post


Link to post
Share on other sites

Did you check if the "temporarily disable jetway movement" option is deactivated for each jetway? It gets activated everytime you move the test sliders until next restart of the sim.

Edited by Marten@Stairport

Share this post


Link to post
Share on other sites

Yes, I always check that the button is set correctly. But even so it doesn’t work even after a fresh sim restart. What I can’t figure out is why everything works at one airport, and doesn’t work at another.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Success!  Everything is working perfectly now!!

I guess this means that I'm using a jetway that's too tall for the small aircraft trying to dock.  But I needed the height to mesh well with the structure of the terminal building.  I'll be sure to keep a closer look at the limits in the future.

Thanks again!

🙂

  • Like 1

Share this post


Link to post
Share on other sites

Alright, here's another one 🙂

I'm working on some gates at PAJN and the 'attached' position of the jetway has decided to have a rotate 2 value of 272.  It wasn't connecting at all (because the limit was 88), but after setting a limit of 300 the cabin of the jetway rotated through itself to get to the 272 degrees.  I had to set the start position to be 300 degrees, so that it wouldn't spin all the way around.  It works, and looks ok, but it seems like that shouldn't be.  Why would the plugin decide that the docked position should be 272, and not -88?  (Yes, I set the lower limit to allow a value of -88 🙂 )
b738_2.thumb.png.5dcff07a2baa71a73210d664eb3b0546.pngb738_1.thumb.png.24dded6bb798c0f389f4f9a1c53b2795.png

Share this post


Link to post
Share on other sites

The rotation is measured relative to the initial object position so the maximum values would be - /+180 degrees. If you pass that it will indeed hit itself. Never tried out to use higher values so not sure what the calculation does in that case. 

You may send me that scenery as well to figure out what's happening here. 

Share this post


Link to post
Share on other sites
16 hours ago, Marten@Stairport said:

Please check the limit values with force connect for those aircrafts. I'm sure you are out of limits as the md80 door is pretty low and the a350 door is high. You will probably have to increase the values. 

@Marten@Stairport But if the jetways connect to the B737 and B772, they should height wise be in the limits? I did try your suggestions, but they didn't work.

Share this post


Link to post
Share on other sites
1 hour ago, Marten@Stairport said:

Not sure if they might changed the identification names in the acf for the 350 after the latest update. That could cause it in case you can't connect it at any airport. Will check that.

@Marten@Stairport I just thought that if the "Force connect for testing" work, then it would work in normal usage.

Share this post


Link to post
Share on other sites
On 12/9/2018 at 4:47 AM, SwedgeHouse said:

Alright, here's another one 🙂

I'm working on some gates at PAJN and the 'attached' position of the jetway has decided to have a rotate 2 value of 272.  It wasn't connecting at all (because the limit was 88), but after setting a limit of 300 the cabin of the jetway rotated through itself to get to the 272 degrees.  I had to set the start position to be 300 degrees, so that it wouldn't spin all the way around.  It works, and looks ok, but it seems like that shouldn't be.  Why would the plugin decide that the docked position should be 272, and not -88?  (Yes, I set the lower limit to allow a value of -88 🙂 )

The door rotation problem was a bug which has been fixed in 1.0.4.

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.



  • To be able to comment, start new topics, download files or get access to certain parts of the forum you will have to be Signed in.

    Sign up to participate

  • Current Donation Goals

  • Threshold News

  • Threshold articles

  • Threshold clubs

×
×
  • Create New...

Important Information

Please read the Terms of Use