Jump to content

Jetway not connecting to A320 Ultimate


Recommended Posts

I have another couple of questions.

1) Is there a possibility to change the order of the jetway animations? I believe it wold look more natural if the order were like this: >Rotate3>Extent>Rotate2>Rotate1 (wheel direction adjustments when needed)

2) There is a possibility to synchronize XP datarefs with FFA320 datarefs using the FFA320 Connector. Which XP datarefs are needed for SAM to function automatically?

Many thanks

Hans

Link to post
Share on other sites
2 hours ago, HaW said:

1) Is there a possibility to change the order of the jetway animations? I believe it wold look more natural if the order were like this: >Rotate3>Extent>Rotate2>Rotate1 (wheel direction adjustments when needed)

No.

2 hours ago, HaW said:

2) There is a possibility to synchronize XP datarefs with FFA320 datarefs using the FFA320 Connector. Which XP datarefs are needed for SAM to function automatically?

sim/cockpit/electrical/beacon_lights_on

Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...
  • 1 month later...
  • 11 months later...

Hi,

I developped a small LUA script to synchronize the FF A320 Beacon with XP11. You need to have FlyWithLUA installed.

Create a new textfile with .lua extension in the script folder, and copy the following script inside the file.

After that, the Jetways  work in automatic mode.

 

 

 

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

-- ffa320-beacon.lua            Copy FF320 Beacon Status to XP11 Beacon status - SAM auto mode working

--                              

-- VERSION: 1.0.0               Author: Marc GAUB : marc@gaub.lu        

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

local DEBUG = 0     -- for debugging

 

-- Functions --

function switch_beacon()    

    DataRefID = XPLMFindDataRef("a320/Overhead/LightBeacon");

    if (DataRefID == NULL)  then    

        if (DEBUG == 1) then

            logMsg("A320 Beacon : DATAREF not existing")

        end

    else

        dataref("xp_paused", "sim/time/paused")

        dataref("a320_beacon_lt", "a320/Overhead/LightBeacon")

        dataref("sim_beacon_lt", "sim/cockpit/electrical/beacon_lights_on", "writable")

        if (xp_paused == 0) then

            if (a320_beacon_lt > 0) then

                if (DEBUG == 1) then

                    logMsg("A320 Beacon : beacon enabled")

                end

                sim_beacon_lt = 1

            else

                if (DEBUG == 1) then

                    logMsg("A320 Beacon : beacon disabled")

                end

                sim_beacon_lt = 0

            end

        end

    end

end

 

-- Main --

if (DEBUG == 1) then

    logMsg("A320 Beacon : Start of FlyWithLUA script")

end

 

if (AIRCRAFT_FILENAME == "A320.acf") then

    do_often("switch_beacon()")

else

    if (DEBUG == 1) then

        logMsg("A320 Beacon : Not in the FF A320 cockpit")

    end

end

 

  • Like 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...

Important Information

Please read the Terms of Use