Jump to content

Something is very wrong


Recommended Posts

The app was working but now it isn't, it's on but I can't get any Metar's, so I uninstalled it but when MSFS load I get a message say that Window can't find xEnviro and it gives this folder path but there is nothing in that folder I'm having trouble because when I redownload it still doesn't work, and it is not asking me for my code. I tried to open a ticket, but they haven't sent me the email to verify the reg. so I turn to this option any help will be appreciated I paid 24.00 because I had on it xPlane but I hate to lose money please help. thanks.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Don't have an account?

    An account is required to interact with and download content from the Threshold Forum.
    Forum is currently also locked down for guests because of heavy bot invasions. Sorry about that.

  • Threshold News

  • image.png.5d3ebd5638179a05dc5cfa67eaf4bf3a.png

  • Create New...

Important Information

Please read the Terms of Use