Jump to content

SAM Jetways AOS bugged by changing date and time. *With Video; reproducible bug"


Recommended Posts

*You may scroll down to the 3rd post for a video describing such, instead*.


Hello, I've been experiencing a few glitches for SAM. Maybe it could be worthy of a bug report, or I simply missed a procedure. Tried opening a ticket, but for some reason, Captcha doesn't want to play nice, and I have searched topics for these problems, some were similar but not quite exact, so here's my post....


1) SAM thinks you're still near the gates even after departure.(Auto or Manual mode, any aircraft). >Screenshot

-As attached in the first screenshot, I was well into my flight from KTPA to KMSY (both airports having SAM Gates). However revealing the AOS, SAM thinks my plane is still in KTPA, and this is significant because I was not able to connect my SAM jetway in KMSY, as it still showed this all along the flight. This was taken in Manual mode, as I was using the FFA320. I tried cycling between Auto and Manual, but it still showed this.


2) SAM sometimes thinks it has connected to the door. (ToLiSs A32X, Auto Mode, Manual Mode.) >Screenshot

-In another screenshot, which was taken 30 seconds after the jetway "docked" into the aircraft, the jetway icon never turned green/disappeared, and still showed the blue icon. Of note, I "cycled" into auto mode, but the icon still showed a blue "M" manual icon.

-I changed the in-sim time, and it managed to connect to the aircraft in Auto mode, icon and all.


3) SAM in Auto mode doesn't disconnect even with beacon light on trigger / doesn't connect even with engines off and beacon light trigger (ToLiSs A32X, Auto Mode) >No screenshot available<

-I don't have a screenshot , but I have to cycle pressing from "Auto" to "Manual" to "Auto" again to disconnect the SAM jetway, in which this method disconnects the jetway without playing the animation. (Or do the same thing to connect the SAM jetway, Engines off, fuel flow zero, beacon light off, still none, still have to cycle Auto-Manual-Auto, which doesn't play the animation, but instantly connects) I'm aware it takes some time for the jetway to disconnect, but in this case, nothing happened even after 30 seconds. 

-In fact, sometimes SAM doesn't detect the jetway at all (The Gray jetway icon in either "A" Auto or "M" Manual mode, which brings us to No.4)


4) SAM sometimes doesn't detect the gates when coming in for parking (Either both types of both Type01/Type02 SAM gates or the MisterX SAM gates) >Screenshot >Log.txt >SAM Log 

-This is the reason why No. 3 happens. So not even the "Gray" jetway icon shows as the screenshot says. I was arriving to the parking stand in that screenshot.

-For this, I spawned at KCHA to test the gate. It worked, so I did my flight from KSFB to KCHA, and then it didn't work (which is when that screenshot was taken).



-All jetways were within installation parameters ("Force Connect to Aircraft" revealed no parameters in the red).

-I've only ever used two planes, ToLiSs (in auto mode) and the FFA320 (in manual mode)

-XP11.53r1, SAM Suite 1.4.3, SAM Base Plugin 2.2.7, SAM Scenery Developer Pack 1.0.4

Edited by SkyBloo
Usage of two planes, Sim Info, changed title
Link to comment
Share on other sites

Might have consistently reproduced bugs that make 1, 3, and 4 happen. Apparently, say if you spawn at a SAM Gate with the engines off, all is normal, SAM gates connected (if in Auto mode)..... until you change the XPlane 11 time. I find that changing the time breaks SAM. At least, that's what I've observed....

Here's my latest (XPlane 11 Log) and (SAM log) regarding Automatic mode in an FF350 in a departure from RPLL to RKSI. When I turned the beacon light on, the jetway didn't automatically disconnect, and in fact, it was still stuck to the aircraft door while I was pushing back. I had to use the AOS to toggle from Auto > Manual, then Manual > Auto (which instantly disconnected the jetway).

Link to comment
Share on other sites

After some experimentation, I was able to... "break" SAM consistently by simply changing the ingame time. It won't work if you change the ingame time, unless you fly in real-time, then SAM and the AOS works properly. For example, you disconnect/connect Manually (same happens in Auto) SAM, but the AOS gets bugged, and you'll have no way to reconnect or disconnect them again...  unless changed to real-time. To further visualize.....

....here's a video I uploaded on YouTube, demonstrating the series of experiments, and reproduction of aforementioned "breaking".

Note: I chose the FFA320 solely because it only operates on Manual mode. I have tried the ToLiSs A321 and the FlightFactor A350 on Auto mode. Both similarly also get this bug, which I found a temporary workaround by doing a "Start New Flight" (which doesn't work here in Manual mode). In this case, Auto mode for the A321 and A350 will "work" in a way: The AoS is bugged, but the jetways connect/disconnect according to the trigger (beacon light off/on, respectively), but the AoS will indicate much like the one in the video. This most likely means that you won't have a reliable way to control the jetways in Manual mode.

Edited by SkyBloo
Link to comment
Share on other sites

  • SkyBloo changed the title to SAM Jetways AOS bugged by changing date and time. *With Video; reproducible bug"

After some more flights and experimentation... changing the time even once after your first spawn / load-in does bug the AoS. All my flights with SAM worked if I didn't change planes, or change times after the first spawn / load-in. If you don't, do either of those, SAM will work all the way. Will follow up here if I get any more significant findings.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Don't have an account?

    An account is required to interact with and download content from the Threshold Forum.
    Forum is currently also locked down for guests because of heavy bot invasions. Sorry about that.

  • Threshold News

  • image.png.5d3ebd5638179a05dc5cfa67eaf4bf3a.png

  • Create New...

Important Information

Please read the Terms of Use