Jump to content

Visibility/Fog Display issue in OpenGL when running Skyscapes (Bug ?) (Partially Solved)


TinkerNZ
 Share

Recommended Posts

Hi @BiologicalNanobot and anybody who is experiencing display issues when running in OpenGL.
I have been posting regards display issues, lines showing up on display when running XP in OpenGL, in the Tech Support on the Org Forum. However as this is the Skyscapes support location, I will post my observations here and link to it in the Org Forum.

I and others have found  lines and artifacts on scenery (tree edges etc) when running Skyscapes in XP OpenGL mode.
After trial and error and comparing results I believe this is linked to the visibility/fog settings and how Skyscapes deals with those. Not something I believe we as users can adjust via the presets config file.

In short when there is a level of fog/haze Skyscapes tries to depict/show this. but fails to do so in OpenGL causing the lines. In Vulkan mode the Fog/Haze is clearly visible, in fact a 10Nm distance view causes rather hazy view conditions. (too much I feel)

Below are 6 screenshots with settings and conditions noted on each image. Noteworthy is that when the visibility is manually pushed out too 100Nm while inn OpenGL mode, the problem disappears. So it must be that which causes the issue.

So if this 'bug' can be fixed and maybe also a Fog Intensity control can be added to the 'presets' controls that would be excellent.

Cheers
TinkerNZ

Edit/Update: With the help from @marc15 on the X-Plane.Org Forum it has been found that the lines graphic display issue was caused by the latest nVidea driver v 516.40.
                      A rolling back to previous ver 512.95 appears to fix the lines issue.
                     It would still be nice to get some control over the intensity with which ES depicts Fog. For example when real weather delivers reduced visibility to say 10km the view is filled with Fog/Low Cloud Haze by ES. Without ES the visibility is more correct at 10km but of course no 3D clouds.

1787877796_ESVisibility-1.jpg.8dad6db2db326ce8f27c444a8373d081.jpg1632729085_ESVisibility-2.jpg.aa757734de65e99406a1ef81856e37c9.jpg279346371_ESVisibility-3.jpg.9ff48288931aa30224bd181d494152d1.jpg1332141143_ESVisibility-4.jpg.1f6e5e3e07ad31d45def1cb46b9145b1.jpg577386888_ESVisibility-5.jpg.8ad632e79c9260b0cd83761fa2b32dec.jpg503797453_ESVisibility-6.jpg.02bcb41a2fe263d30610b2855f284258.jpg

Edited by TinkerNZ
Info Update
  • Like 1
Link to comment
Share on other sites

  • TinkerNZ changed the title to Visibility/Fog Display issue in OpenGL when running Skyscapes (Bug ?) (Partially Solved)
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

Announcements



  • Don't have an account?

    An account is required to interact with and download content from the Threshold Forum.
    Forum is currently also locked down for guests because of heavy bot invasions. Sorry about that.

  • Threshold News

  • Tell a friend

    Love Threshold? Tell a friend!
×
×
  • Create New...

Important Information

Please read the Terms of Use

But sadly we're dependent on them to be able to give you this free service. 

Please consider donating. By doing that you will get a rank that doesn't show ad-sense ads.
(You can reach that rank by just being active too - so no donation is mandatory at any level)

But if you can, please disable your adblocker so we can cover our expenses