Jump to content

SAM3 Won't let me activate


Recommended Posts

Hi guys so I've had SAM for a bit and just decided to update to SAM3 when it first came up and tried to activate it but I keep having the same issue so I just decided to go back to the old version but I still keep on getting this issue that it won't let me paste my key or email or even write it I've tried cntrl+v and the paste button to no avail any idea how to fix it? 



Link to comment
Share on other sites

On 1/31/2022 at 9:24 AM, Marten@Stairport said:

Can you please type the email adress into your browser URL and then copy it from there without any blank space? If that still doesn't work please open a ticket via support@stairport-sceneries.com and add you purchase email.

That worked thanks!

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Don't have an account?

    An account is required to interact with and download content from the Threshold Forum.
    Forum is currently also locked down for guests because of heavy bot invasions. Sorry about that.

  • Threshold News

  • image.png.5d3ebd5638179a05dc5cfa67eaf4bf3a.png

  • Create New...

Important Information

Please read the Terms of Use