Jump to content

CTD's when Follow Me is installed


Recommended Posts

Hello,

When flying with the Follow Me add-on I often get a CTD. This can be in any phase of the flight. I've had it while vacating, on final, just before final, in cruise and after take-off. It also occurred with multiple aircraft like the ToLiss a319, the Aerobask Epic Victory and the FlyJSim 727.

When I uninstall the follow me add-on I have no problems it seems. I've tried to uninstall the add-on a few times, fly some flights then reinstall and see what happens and the CTD's returned.

Reading the logs I don't see exactly what happened. I have a crash dump file, but it doesn't always generate a file. The sims crashes without showing me the crash report screen from XP11 itself.

I used the latest versions (installed with SAM Suite with Admin rights):
Base 2.2.2
FM: 1.0.3

 

I hope you guys can help.

 

Logs can be found here: https://we.tl/t-Kjcef2MP9q

Edited by Sluijsens
Added versions
Link to post
Share on other sites

Judging from the logs it's not related to follow me but to AirportVehicles. Probably a VRAM overflow when too many vehicles are being drawn.

If you receive an XP crash information that crash is NOT caused by SAM because if SAM crashes it will not show any report but write the necessary debug information silently into sam.log. This is to prevent you from sending SAM crashes to Laminar because they don't care about it 😉

Please replace the airport vehicles files with this low res mod: http://sam-suite.com/SAM_AirportVehicles_LOW-RES-MOD.zip

And report back if the issue still occurs.

Link to post
Share on other sites

Thanks for the quick response. I'll try it out, but to be honest I doubt it'll make a difference.

Weird thing is that it also happens when I'm above water or just after take-off which should be 2 phases where not much is going on in terms of loading in new objects. Also, these crashes all happened when I didn't use the follow me add-on. It was just installed. The few times I did use the add-on no crashes occurred. Besides that is that my settings are already way lower than they used to be before I reinstalled x-plane. Before that nothing was wrong.

Anyway, I'll try and report back whenever I have something to report.

Edited by Sluijsens
Link to post
Share on other sites

A lot actually:

image.png.75b73193382144227f9edf6df4fc5ae0.png

Where GndHandling was just installed like 2-3 flights ago as well as de xjet plugin for the Airfoillabs which I just installed yesterday.
The pluings marked with a green line are installed but not touched.

Flywithlua plugins (all are untouched during these flights but are loaded)

  • Autospeed (which was also installe dlater than the crashes happened)
  • PassengersFX
  • B2VolumeControl

I only have 1 network plugin enabled at all times (so either IVAO, POSCON or FSCloud) and I encountered crashes with all 3 of them.

For the weather add-ons I rotated them around thinking it was one of them at first. Only 1 of the weather add-ons is enabled at a time (obviously, but just mentioning). I think I also tried default clouds, but I'll try that next time as well.

As for the SAM add-ons. At one point I disabled them all, did some flight and had no trouble. Then I gradually enabled them doing some flights before enabling the next add-on starting with the Jetways. Second was the Vehicles plugin and all was fine. After enabling the Follow Me again the crashes started happening again.

I don't always use the Follow Me because I don't always need it, but the times I actually used it it were flights I did not crash. However, those were only a few flights so I might've been lucky there.

Link to post
Share on other sites

First you shouldn't run DatarefTool if you are not a developer and need to have access to datarefs. It's continously polling all XP datarefs which is not good for the average use.

Again this crash is not caused by FollowMe so you should be fine using it. I would try to switch off weather addons to see if it happens again (using the same test scenario is a plus).

Link to post
Share on other sites
  • 2 weeks later...

I have been flying some flights with only some necessary add-ons and the SAM plug-ins and enabling more add-ons as I go. I had only 1 crash which was not related to SAM at all I think.

The reason I thought it was the Follow Me was because the crashes stopped when I disabled it and started again when it was enabled.
Thanks for your help and sorry for bothering you with this issue.

You can consider this solved. If something is going to happen in the future I'll just create another thread.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...

Important Information

Please read the Terms of Use